基于CNAS标准体系规范的实验室管理系统（后文简称CNAS系统）是在符合cnas标准体系的基础上，通过将标准化实验室的管理制度化，制度流程化，流程表单化，表单信息化，系统核心在于对实验室运行过程中产生的大量表单的信息化。将标准化实验室的管理由粗放到精细、从“线下”到“线上”，强化实验室运行管理、提升管理效率。在实验室数据信息化后，通过大数据分析来进行实验室的高层次的管理，加强数据分析，提升标准化实验室的管理水平。

取数端作为本系统的一个子模块，实现了实验数据从实验室仪器到系统数据库的传输，为后续数据处理和分析提供基础。


1 CNAS系统业务数据库配置

CNAS系统业务数据库用于存储CNAS系统相关业务数据。

填写CNAS系统业务数据库连接所需要的参数。分别包括服务器IP，实例，用户名，密码，端口。这些信息可以通过CNAS系统管理员或DBA获得。

初步配置完成后，可以点击“测试连接”按钮进行测试。如果能够正常连接数据库，则提示“连接成功”。

配置完成后，点击“确定”按钮，取数端将会把填写的信息加密后存储在本地文件中，下次打开界面时将显示这些信息。但“确定”按钮提供的是当前整个界面的存储功能，所以我们建议您在当前界面参数全部配置完成后再点击“确定”按钮进行存储。


2 CNAS系统平台数据库配置

选择界面中的“平台数据库”，可以切换到CNAS系统平台数据库配置界面。

填写CNAS系统平台数据库连接所需要的参数。分别包括服务器IP，实例，用户名，密码，端口。这些信息可以通过CNAS系统管理员或DBA获得。

初步配置完成后，可以点击“测试连接”按钮进行测试。如果能够正常连接数据库，则提示“连接成功”。

配置完成后，点击“确定”按钮，取数端将会把填写的信息加密后存储在本地文件中，下次打开界面时将显示这些信息。但“确定”按钮提供的是当前整个界面的存储功能，所以我们建议您在当前界面参数全部配置完成后再点击“确定”按钮进行存储。


3 操作密码配置

因为在取数端的使用过程中，部分配置信息或操作不允许另外的人员进行更改，所以我们提供了操作密码功能。

切换到“操作密码”界面，我们可以在这个界面进行操作密码的设置。

默认情况下，操作密码为123456。您可以在该界面输入新的操作密码。设置完成后，若另外操作人员不知道操作密码，将无法对设置的字段映射等相关配置进行修改或删除。


1 菜单栏功能

点击“数据库配置”，实现第二节内容。略。

点击“同步配置”，实现第三节内容。略。


4 数据上传

点击“执行上传”按钮，将实现第3.3节中选中项的数据上传。

此外，取数端可以进行自动上传，配置好自动服务后，启动服务，可以在本界面可以关闭状态下自动执行上传数据。


2 远程读取仪器数据

当仪器数据源（Excel,Access,SQLite）不是本地数据源，而是来自于局域网内的其他PC机时，需要进行配置。

1. 将数据源文件所在文件夹共享。

2. 来源数据源配置。

远程用户名：表示访问这台电脑的账号

远程密码：表示访问这台电脑的账号密码

3. 在服务安装PC机中更改用户

右键“计算机”-“管理”-“服务”

找到“SyncService”,右键“属性”

在“属性”的“登录”页签中，输入当前电脑的一个拥有管理员权限的账号和密码。

点击“应用”-“确定”后，配置完成。


3 日志文件查看

程序目录中存在ErrorLog，Log，ServiceLog三个文件夹，分别用来存储程序错误日志，执行日志，服务执行日志。可以通过查看文件夹内容查阅相关内容。